Resolved
Our service provider informed us that the database is back to its original state and is performing as expected. We are seeing that all is working as expected.
Resolved
We can confirm the backlog for all clients is back to normal. There is still an upgrade process running in the background, but at the moment, it has no client impact. The service provider and the team are monitoring the situation.
Resolved
The fix applied by our service partner seems to be effective, as the backlog is declining and already gone for most, except for one client. We will still keep monitoring the situation and post another update.
Monitoring
Our partner for the underlying database informed us that they performed a manual recovery operation, which shows good system metrics. They are monitoring the situation. We hope the situation can be resolved soon.
Investigating
We confirmed a problem with our system (internal database) and our service partner is currently investigating its root cause. We will provide an update once we have identified the underlying problem.
Identified
We have identified the underlying problem and are now working on a fix. We will provide another update once the fix is rolled out.
Investigating
We are currently investigating an issue with one of our database clusters that is causing a delay in data processing. As a result, some customers may notice that their real-time analytics dashboards are showing "stale" data or a processing lag of approximately 20–30 minutes.